For status updates on other Change Healthcare solutions, please visit us at Change Healthcare Solution Status. The statuses and contact information listed below are only for Enterprise Imaging solutions.
Get email notifications whenever CHCIMAGING creates, updates or resolves an incident.
Get text message notifications whenever CHCIMAGING creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
As part of our commitment to providing a robust and secure analytics experience, Stratus Imaging Analytics has undergone a significant infrastructure upgrade. We are actively migrating our customers to this enhanced platform to ensure continued excellence in performance and reliability.
Current Status of Migration: - The new infrastructure is fully implemented, with over twenty early adopter organizations already benefiting from the upgraded solution. - Over half of our Stratus Imaging Analytics customers are currently in the migration process, with new migrations initiated daily. - If your organization has not yet begun migrating, please expect to hear from our team soon.
Migration Process Overview: 1. Engagement: Your Account Executive or Customer Success Manager will reach out to confirm readiness for your migration. 2. Preparation: We will provide detailed preparatory instructions via email, including necessary whitelisting for IPs, URL, and Port. 3. Configuration and Testing: A Technical Engineer will coordinate a screen-sharing session to complete final configurations on the server where Stratus Imaging Analytics is installed. You will then test and confirm successful access to the new platform.
We look forward to re-welcoming you to the new and improved Stratus Imaging Analytics platform!
Posted Nov 07, 2024 - 09:30 PST
Update
We are continuing to work on a fix for this issue.
Posted May 10, 2024 - 10:36 PDT
Identified
This message is to inform you that, pursuant to our efforts described at status.changehealthcare.com, interconnectivity between some systems has been suspended. These suspensions have temporarily impacted the ability of Stratus Imaging Analytics users to access their data. We are actively pursuing options to bring the system back online.
At this time, we are unable to provide an estimated time for this service to be restored.